You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
You are viewing the article in preview mode. It is not live at the moment.
Home > General Information > NMXi LCD Screen Won't Turn Off
NMXi LCD Screen Won't Turn Off
print icon

Problem Description

The NMXi safe's LCD screen remains on continuously and won't turn off, even after troubleshooting steps like unpairing/repairing WiFi and clearing tamper warnings.

Root Cause

This issue is typically caused by a fully depleted battery, especially in units that are kept plugged in indefinitely.

Solution

Replace the battery with a Vaultek-approved replacement battery. Choose Lithium-ion(18650)Flat Top type when purchasing, and only use name-brand batteries for safety reasons.

Important Battery Safety Information

Battery Selection Guidelines

  • Always use a fresh battery instead of an old one
  • Never use a battery with any noticeable physical damage, as it may not be safe
  • Use name brands only - do not buy unknown brands, as they may not be safe due to inferior quality

Battery Maintenance Schedule

  • Change your battery every 2 years - this is especially critical for rechargeable batteries to prevent potential electronic failure and safety hazards caused by overheating and fast drainage
  • Warning: If your battery has been used for more than 2 years, replace it with a new battery right away

Power Management

  • It is not recommended to keep the safe plugged in with external power unless required in certain models, such as Vaultek Wi-Fi safes, including Wi-Fi slider, MX, and RS safes
Feedback
0 out of 0 found this helpful

scroll to top icon